php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80912 wrong range() result
Submitted: 2021-03-28 07:28 UTC Modified: 2021-03-28 10:12 UTC
From: np25071984 at gmail dot com Assigned:
Status: Not a bug Package: Math related
PHP Version: 8.0.3 OS: mac os Darwin
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: np25071984 at gmail dot com
New email:
PHP Version: OS:

 

 [2021-03-28 07:28 UTC] np25071984 at gmail dot com
Description:
------------
Since version 7.0.3 I get wrong result (without the last element).

Test script:
---------------
var_dump(range( 0.1, 1.2, 0.1 ));

Expected result:
----------------
array(12) {
  [0]=>
  float(0.1)
  [1]=>
  float(0.2)
  [2]=>
  float(0.3)
  [3]=>
  float(0.4)
  [4]=>
  float(0.5)
  [5]=>
  float(0.6)
  [6]=>
  float(0.7)
  [7]=>
  float(0.8)
  [8]=>
  float(0.9)
  [9]=>
  float(1)
  [10]=>
  float(1.1)
  [10]=>
  float(1.2)
}

Actual result:
--------------
array(11) {
  [0]=>
  float(0.1)
  [1]=>
  float(0.2)
  [2]=>
  float(0.3)
  [3]=>
  float(0.4)
  [4]=>
  float(0.5)
  [5]=>
  float(0.6)
  [6]=>
  float(0.7)
  [7]=>
  float(0.8)
  [8]=>
  float(0.9)
  [9]=>
  float(1)
  [10]=>
  float(1.1)
}

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-03-28 10:12 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2021-03-28 10:12 UTC] requinix@php.net
Floating point values have a limited precision. Hence a value might
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jan 29 07:03:34 2022 UTC