php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80903 opcache with file_cache as secondary segfaults php-fpm
Submitted: 2021-03-24 14:13 UTC Modified: -
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: jorritdeklerk at gmail dot com Assigned:
Status: Open Package: opcache
PHP Version: 7.4.16 OS: FreeBSD 12.2-RELEASE-p4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jorritdeklerk at gmail dot com
New email:
PHP Version: OS:

 

 [2021-03-24 14:13 UTC] jorritdeklerk at gmail dot com
Description:
------------
On both a productionserver and development server php-fpm SOMETIMES crashes when opcache file_cache is enables as secondary cache resulting in 503 errors. The problem goes automatically away when opcache restarts after 180 seconds or when php-fpm is restarted AND the opcache file dir is emptied.

The problem does not occur when file_cache is disabled or when file_cache_only is true.

php.ini

opcache.enable=1
opcache.memory_consumption=128
opcache.interned_strings_buffer=16
opcache.validate_timestamps=1
opcache.revalidate_freq=1 (also tried 0 and 60)
opcache.file_cache="/dir/to/opcache/"
opcache.force_restart_timeout=180
;opcache.file_cache_only=1
opcache.use_cwd=1

http-error.log

[Wed Mar 24 14:33:36.629648 2021] [proxy_fcgi:error] [pid 35068:tid 34385076736] [client 192.168.2.16:14655] AH01067: Failed to read FastCGI header, referer: https://example.com/admin/plugins.php
[Wed Mar 24 14:33:36.629670 2021] [proxy_fcgi:error] [pid 35068:tid 34385076736] (70014)End of file found: [client 192.168.2.16:14655] AH01075: Error dispatching request to : , referer: https://example.com/admin/plugins.php

/var/log/php-fpm.log

[24-Mar-2021 14:33:36] WARNING: [pool www] child 43384 exited on signal 11 (SIGSEGV) after 0.241076 seconds from start
[24-Mar-2021 14:33:36] NOTICE: [pool www] child 44577 started

There are no problems reported when I activate an opcache log (no (fatal) errors).

Problem most of the time occurs after changing / adding code to application (both tested on own application and Moodle 3.10).

Tried different memory_consumptions (very small to very big); no luck.

Maybe related to Bug #75670 and Bug #80154,

Disabling file_cache for now.


Patches

Add a Patch

Pull Requests

Add a Pull Request

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Aug 03 08:01:25 2021 UTC