php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80702 cannot configure/compile rrdtool
Submitted: 2021-02-03 10:26 UTC Modified: 2021-02-03 11:47 UTC
From: michel dot henaut at everyware dot ch Assigned: cmb (profile)
Status: Not a bug Package: rrd (PECL)
PHP Version: 7.4.14 OS: Ubuntu 20
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michel dot henaut at everyware dot ch
New email:
PHP Version: OS:

 

 [2021-02-03 10:26 UTC] michel dot henaut at everyware dot ch
Description:
------------
1 - copy in /ext/rrdtool files
2 - run configure ...,--with_rrdtool,...
configure answer : unrecognized options --with_rrdtool
I ran in ext/rrdtool phpize and configure again - no effect
NB: this option is working with php-5.1.14, but not in php-5.1.27, php 7.4.1, 8.0.1
with_rrdtool=shared is not working



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-02-03 10:51 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2021-02-03 10:51 UTC] cmb@php.net
> --with_rrdtool

Shouldn't that be --with-rrdtool?  Also, you need to do
./buildconf, unless you ./phpize.
 [2021-02-03 10:55 UTC] cmb@php.net
-Package: *Compile Issues +Package: rrd
 [2021-02-03 11:18 UTC] michel dot henaut at everyware dot ch
-Status: Feedback +Status: Closed
 [2021-02-03 11:18 UTC] michel dot henaut at everyware dot ch
Is fixed - needed was ./buildconf --force
 [2021-02-03 11:47 UTC] cmb@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Nov 29 15:03:13 2021 UTC