php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80667 checking for libxml-2.0 >= 2.7.6... no
Submitted: 2021-01-25 11:26 UTC Modified: 2021-01-25 13:22 UTC
From: stuart dot salter at dieboldnixdorf dot com Assigned: cmb (profile)
Status: Not a bug Package: *XML functions
PHP Version: 7.4.14 OS: Solaris 10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: stuart dot salter at dieboldnixdorf dot com
New email:
PHP Version: OS:

 

 [2021-01-25 11:26 UTC] stuart dot salter at dieboldnixdorf dot com
Description:
------------
trying to configure using the following command:

/app/INSTALL_FILES/php-7.4.13

./configure --with-apxs2=/usr/apache2/bin/apxs --with-gd --with-zlib --disable-ipv6 --with-jpeg-dir=/usr/local --with-png-dir=/usr/local --with-freetype-dir=/usr/local --with-pear --with-openssl -with-openssl --with-mysql --enable-bcmath --enable-ctype --enable-sockets --enable-mbstring --with-gettext --prefix=/usr/php
# pwd

but I get this error:

Configuring extensions
checking io.h usability... no
checking io.h presence... no
checking for io.h... no
checking for strtoll... yes
checking for atoll... yes
checking whether to build with LIBXML support... yes
checking for libxml-2.0 >= 2.7.6... no
configure: error: in `/app/INSTALL_FILES/php-7.4.13':	
configure: error: The pkg-config script could not be found or is too old.  Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

this link suggests that I need pkg-config:

	https://bugs.php.net/bug.php?id=79135

so I’ve downloaded and configured that package:
	
	/app/INSTALL_FILES/pkg-config-0.29.2
# ./configure --with-internal-glib

but I get this error when I try ‘make’ command:

# CC=gcc
# export CC
# make
make  all-recursive
Making all in glib
make  all-recursive
Making all in .
Making all in m4macros
make  all-am
Making all in glib
make  all-recursive
Making all in libcharset
make  all-am
Making all in .
  CC       libglib_2_0_la-gconvert.lo
gconvert.c:61:2: #error GNU libiconv not in use but included iconv.h is from libiconv
gconvert.c: In function `g_iconv':




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-01-25 12:28 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2021-01-25 12:28 UTC] cmb@php.net
So you're having an issue configuring pkg-config?  That doesn't
look like a PHP issue.
 [2021-01-25 12:56 UTC] stuart dot salter at dieboldnixdorf dot com
Hi there,

thanks for the reply, well I'm trying to install PHP 7.4 and the original error is with that !

checking for libxml-2.0 >= 2.7.6... no
configure: error: in `/app/INSTALL_FILES/php-7.4.13':	
configure: error: The pkg-config script could not be found or is too old.  Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

so I'm trying to use pkg-config, as it suggests but then getting the new error:

/app/INSTALL_FILES/pkg-config-0.29.2
# ./configure --with-internal-glib

but I get this error when I try ‘make’ command:

# CC=gcc
# export CC
# make
make  all-recursive
Making all in glib
make  all-recursive
Making all in .
Making all in m4macros
make  all-am
Making all in glib
make  all-recursive
Making all in libcharset
make  all-am
Making all in .
  CC       libglib_2_0_la-gconvert.lo
gconvert.c:61:2: #error GNU libiconv not in use but included iconv.h is from libiconv
gconvert.c: In function `g_iconv':
 [2021-01-25 13:22 UTC] cmb@php.net
Sorry, we cannot help with the installation of third-party tools,
even if they are required for building PHP.  Please consult an
appropriate support channel for pkg-config and/or Solaris.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Dec 05 14:05:52 2022 UTC