php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8062 $HTTP_COOKIE_VARS
Submitted: 2000-11-30 18:52 UTC Modified: 2000-12-02 23:13 UTC
From: sam at samware dot net Assigned:
Status: Closed Package: Variables related
PHP Version: 4.0.3pl1 OS: FreeBSD 4.1.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
50 - 48 = ?
Subscribe to this entry?

 
 [2000-11-30 18:52 UTC] sam at samware dot net
I am using PHP 403pl1 with Apache 1.3.14. Everything works great except for $HTTP_COOKIE_VARS. It never returns a value. I can retrieve the value via $GLOBALS but I would prefer to stick with $HTTP_COOKIE_VARS. This worked fine until I installed 403pl1 :)

I would be glad to supply more info if needed.

Regards,
Sam Beckwith
sam@samware.net

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-30 21:32 UTC] sniper@php.net
$HTTP_COOKIE_VARS is working just fine for me. 
Please add some example code in which it doesn't work right.

--Jani
 [2000-12-01 16:28 UTC] zak@php.net
Globally-scoped variables are not imported into the namespace of a class by default.  Globally-scoped variable must be imported into local scopes (like class and function definitions) using the globals keyword.

This is not a bug - it is simply the way that the language works.

At 03:05 PM 12/1/00 -0600, you wrote:
> I have more details.  The problem only occurs within a 
> Class method.  To correct the problem I used:
>
>    global $HTTP_COOKIE_VARS;
>
> It is my understanding that $HTTP_COOKIE_VARS should 
> already be global as is $HTTP_SERVER_VARS etc...
>
> Regards,
> Sam Beckwith
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Dec 10 02:01:24 2019 UTC