php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80581 can't compile
Submitted: 2021-01-04 09:52 UTC Modified: 2021-06-02 14:53 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: 9801836 at qq dot com Assigned:
Status: Duplicate Package: Compile Failure
PHP Version: 7.4.13 OS: CentOS 7.4 64bit with ARM
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: 9801836 at qq dot com
New email:
PHP Version: OS:

 

 [2021-01-04 09:52 UTC] 9801836 at qq dot com
Description:
------------
---
From manual page: https://php.net/faq.build
---
can't make:

/root/lnmp1.7/src/php-7.4.12/ext/standard/array.c: In function ‘zif_array_sum’:
/root/lnmp1.7/src/php-7.4.12/Zend/zend_operators.h:674:2: error: invalid 'asm': invalid operand prefix '%c'
  __asm__ goto(
  ^
make: *** [ext/standard/array.lo] Error 1
make: *** Waiting for unfinished jobs....



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-06-02 14:53 UTC] derick@php.net
-Status: Open +Status: Duplicate
 [2021-06-02 14:53 UTC] derick@php.net
Duplicate of #75951
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 23 00:03:38 2021 UTC