php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8055 doesn't recognize ntext data type
Submitted: 2000-11-30 12:54 UTC Modified: 2001-05-11 21:29 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: jeremy dot brooks at bams dot com Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.0.3pl1 OS: NT Server 4 sp6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jeremy dot brooks at bams dot com
New email:
PHP Version: OS:

 

 [2000-11-30 12:54 UTC] jeremy dot brooks at bams dot com
On MS SQL Server 7 PHP NT Server 4 sp6 Apache 1.3.11...In a SELECT statement containing a reference to an ntext (national text) data field; PHP either ignores everything in the script after the cursor declaration or throws an Apache error 500 (server config error). Converted ntext to text, works fine. INSERT's work fine in ntext, however. nvarchar seems to work OK.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-06 04:38 UTC] cynic@php.net
duplicate of #8541

fmk@php.net:
This is not an error in the MS SQL extension, as you are using ODBC functions to fetch
data.
Microsofts new datatypes ntext nad nvarchar is not suported in the MS SQL extension, as
they are not supported in Microsofts C-library. The will always be returned as a varchar with
a max length of 255 bytes.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun May 22 21:05:44 2022 UTC