php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80474 Error when make
Submitted: 2020-12-03 03:20 UTC Modified: 2021-03-16 14:13 UTC
Votes:6
Avg. Score:4.7 ± 0.7
Reproduced:6 of 6 (100.0%)
Same Version:5 (83.3%)
Same OS:4 (66.7%)
From: minhhiep dot duong at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: imagick (PECL)
PHP Version: 8.0.0 OS: CentOS 8 - 5.9.6-1.el8.elrepo.x8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: minhhiep dot duong at gmail dot com
New email:
PHP Version: OS:

 

 [2020-12-03 03:20 UTC] minhhiep dot duong at gmail dot com
Description:
------------
[root@localhost imagick-3.4.4]# make
/bin/sh /soft/imagick-3.4.4/libtool --mode=compile cc -I. -I/soft/imagick-3.4.4 -I/soft/imagick-3.4.4/include -I/soft/imagick-3.4.4/main -I/soft/imagick-3.4.4 -I/usr/local/php_8/include/php -I/usr/local/php_8/include/php/main -I/usr/local/php_8/include/php/TSRM -I/usr/local/php_8/include/php/Zend -I/usr/local/php_8/include/php/ext -I/usr/local/php_8/include/php/ext/date/lib -I/usr/include/ImageMagick-6  -DHAVE_CONFIG_H  -g -O0   -I/usr/include/ImageMagick-6 -fopenmp -DMAGICKCORE_HDRI_ENABLE=0 -DMAGICKCORE_QUANTUM_DEPTH=16  -c /soft/imagick-3.4.4/imagick_file.c -o imagick_file.lo
mkdir .libs
 cc -I. -I/soft/imagick-3.4.4 -I/soft/imagick-3.4.4/include -I/soft/imagick-3.4.4/main -I/soft/imagick-3.4.4 -I/usr/local/php_8/include/php -I/usr/local/php_8/include/php/main -I/usr/local/php_8/include/php/TSRM -I/usr/local/php_8/include/php/Zend -I/usr/local/php_8/include/php/ext -I/usr/local/php_8/include/php/ext/date/lib -I/usr/include/ImageMagick-6 -DHAVE_CONFIG_H -g -O0 -I/usr/include/ImageMagick-6 -fopenmp -DMAGICKCORE_HDRI_ENABLE=0 -DMAGICKCORE_QUANTUM_DEPTH=16 -c /soft/imagick-3.4.4/imagick_file.c  -fPIC -DPIC -o .libs/imagick_file.o
In file included from /soft/imagick-3.4.4/imagick_file.c:22:
/soft/imagick-3.4.4/php_imagick_file.h:61:108: error: expected ‘;’, ‘,’ or ‘)’ before ‘TSRMLS_DC’
 zend_bool php_imagick_file_init(struct php_imagick_file_t *file, const char *filename, size_t filename_len TSRMLS_DC);
                                                                                                            ^~~~~~~~~
/soft/imagick-3.4.4/php_imagick_file.h:65:54: error: expected ‘;’, ‘,’ or ‘)’ before ‘TSRMLS_DC’
 int php_imagick_safe_mode_check(const char *filename TSRMLS_DC);
                                                      ^~~~~~~~~
In file included from /soft/imagick-3.4.4/imagick_file.c:22:
/soft/imagick-3.4.4/php_imagick_file.h:68:134: error: expected ‘;’, ‘,’ or ‘)’ before ‘TSRMLS_DC’
 php_imagick_rw_result_t php_imagick_read_file(php_imagick_object *intern, struct php_imagick_file_t *file, ImagickOperationType type TSRMLS_DC);
                                                                                                                                      ^~~~~~~~~
/soft/imagick-3.4.4/php_imagick_file.h:71:153: error: expected ‘;’, ‘,’ or ‘)’ before ‘TSRMLS_DC’
 php_imagick_rw_result_t php_imagick_write_file(php_imagick_object *intern, struct php_imagick_file_t *file, ImagickOperationType type, zend_bool adjoin TSRMLS_DC);
                                                                                                                                                         ^~~~~~~~~
/soft/imagick-3.4.4/php_imagick_file.h:74:112: error: expected ‘;’, ‘,’ or ‘)’ before ‘TSRMLS_DC’
 zend_bool php_imagick_stream_handler(php_imagick_object *intern, php_stream *stream, ImagickOperationType type TSRMLS_DC);
                                                                                                                ^~~~~~~~~
/soft/imagick-3.4.4/imagick_file.c:81:51: error: expected ‘;’, ‘,’ or ‘)’ before ‘TSRMLS_DC’
 zend_bool php_imagick_is_url(const char *filename TSRMLS_DC)
                                                   ^~~~~~~~~
/soft/imagick-3.4.4/imagick_file.c:91:108: error: expected ‘;’, ‘,’ or ‘)’ before ‘TSRMLS_DC’
 zend_bool php_imagick_file_init(struct php_imagick_file_t *file, const char *filename, size_t filename_len TSRMLS_DC)
                                                                                                            ^~~~~~~~~
/soft/imagick-3.4.4/imagick_file.c:160:133: error: expected ‘;’, ‘,’ or ‘)’ before ‘TSRMLS_DC’
 int php_imagick_read_image_using_imagemagick(php_imagick_object *intern, struct php_imagick_file_t *file, ImagickOperationType type TSRMLS_DC)
                                                                                                                                     ^~~~~~~~~
/soft/imagick-3.4.4/imagick_file.c:201:133: error: expected ‘;’, ‘,’ or ‘)’ before ‘TSRMLS_DC’
 int php_imagick_read_image_using_php_streams(php_imagick_object *intern, struct php_imagick_file_t *file, ImagickOperationType type TSRMLS_DC)
                                                                                                                                     ^~~~~~~~~
/soft/imagick-3.4.4/imagick_file.c:255:54: error: expected ‘;’, ‘,’ or ‘)’ before ‘TSRMLS_DC’
 int php_imagick_safe_mode_check(const char *filename TSRMLS_DC)
                                                      ^~~~~~~~~
/soft/imagick-3.4.4/imagick_file.c:269:134: error: expected ‘;’, ‘,’ or ‘)’ before ‘TSRMLS_DC’
 php_imagick_rw_result_t php_imagick_read_file(php_imagick_object *intern, struct php_imagick_file_t *file, ImagickOperationType type TSRMLS_DC)
                                                                                                                                      ^~~~~~~~~
/soft/imagick-3.4.4/imagick_file.c:288:153: error: expected ‘;’, ‘,’ or ‘)’ before ‘TSRMLS_DC’
 php_imagick_rw_result_t php_imagick_write_file(php_imagick_object *intern, struct php_imagick_file_t *file, ImagickOperationType type, zend_bool adjoin TSRMLS_DC)
                                                                                                                                                         ^~~~~~~~~
/soft/imagick-3.4.4/imagick_file.c:313:112: error: expected ‘;’, ‘,’ or ‘)’ before ‘TSRMLS_DC’
 zend_bool php_imagick_stream_handler(php_imagick_object *intern, php_stream *stream, ImagickOperationType type TSRMLS_DC)
                                                                                                                ^~~~~~~~~
make: *** [Makefile:209: imagick_file.lo] Error 1

Test script:
---------------
After "./configure --build=x86_64-redhat-linux --bindir=/usr/local/php_8/bin --sbindir=/usr/local/php_8/sbin --libexecdir=/usr/local/php_8/libexec --libdir=/usr/local/php_8/lib64 --includedir=/usr/local/php_8/include --sysconfdir=/usr/local/php_8/etc --with-php-config=/usr/local/php_8/bin/php-config --with-imagick=/usr/local/php_8 --with-gnu-ld" then make and it show error


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-12-03 03:28 UTC] requinix@php.net
-Package: Compile Failure +Package: imagick -Assigned To: +Assigned To: danack
 [2020-12-03 03:28 UTC] requinix@php.net
imagick is not yet compatible with PHP 8. Be patient.
 [2020-12-03 03:38 UTC] rtrtrtrtrt at dfdfdfdf dot dfd
3.4.4 	stable 	2019-05-02

how could that be compatible with PHP8?

it's a known problem that PECL extensions are mostly based on luck when and if they ever get updates for many years, 99% of all pecl-extensions are completly unmaintained and nobody cares at least to mark them somehow
 [2021-03-16 14:13 UTC] cmb@php.net
-Status: Assigned +Status: Duplicate -Assigned To: danack +Assigned To: cmb
 [2021-03-16 14:13 UTC] cmb@php.net
Duplicate of bug #80464.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Apr 14 18:01:23 2021 UTC