php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80469 compile issue with PHP 8
Submitted: 2020-12-02 10:00 UTC Modified: 2021-05-17 10:58 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: shop1 at mokraemer dot de Assigned: cmb (profile)
Status: Duplicate Package: xdiff (PECL)
PHP Version: 8.0.0 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: shop1 at mokraemer dot de
New email:
PHP Version: OS:

 

 [2020-12-02 10:00 UTC] shop1 at mokraemer dot de
Description:
------------
some compile issues, e.g.
xdiff.c:41:6: warning: implicit declaration of function 'ZEND_ARG_PASS_INFO'; did you mean 'ZEND_ARG_OBJ_INFO'? [-Wimplicit-function-declaration]
   41 |      ZEND_ARG_PASS_INFO(0)
      |      ^~~~~~~~~~~~~~~~~~
      |      ZEND_ARG_OBJ_INFO
xdiff.c:41:6: warning: initialization of 'const char *' from 'int' makes pointer from integer without a cast [-Wint-conversion]
xdiff.c:41:6: note: (near initialization for 'xdiff_arg_force_ref[1].name')
xdiff.c:41:6: error: initializer element is not constant
xdiff.c:41:6: note: (near initialization for 'xdiff_arg_force_ref[1].name')
xdiff.c:42:6: error: expected '}' before 'ZEND_ARG_PASS_INFO'
   42 |      ZEND_ARG_PASS_INFO(0)
      |      ^~~~~~~~~~~~~~~~~~
In file included from /usr/include/php/main/php.h:35,
                 from xdiff.c:25:
/usr/include/php/Zend/zend_API.h:168:47: note: to match this '{'
  168 |  static const zend_internal_arg_info name[] = { \
      |                                               ^
/usr/include/php/Zend/zend_API.h:171:2: note: in expansion of macro 'ZEND_BEGIN_ARG_INFO_EX'
  171 |  ZEND_BEGIN_ARG_INFO_EX(name, {}, ZEND_RETURN_VALUE, -1)
      |  ^~~~~~~~~~~~~~~~~~~~~~
xdiff.c:40:2: note: in expansion of macro 'ZEND_BEGIN_ARG_INFO'
   40 |  ZEND_BEGIN_ARG_INFO(xdiff_arg_force_ref, 0)
      |  ^~~~~~~~~~~~~~~~~~~



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-12-03 08:57 UTC] david dot navarro at qipsius dot com
The same thing happens with the ssh2 package:

/tmp/pear/temp/ssh2/ssh2.c:49:2: warning: implicit declaration of function 'ZEND_ARG_PASS_INFO'; did you mean 'ZEND_ARG_OBJ_INFO'? [-Wimplicit-function-declaration]
ZEND_ARG_PASS_INFO(1)
^~~~~~~~~~~~~~~~~~
ZEND_ARG_OBJ_INFO
/tmp/pear/temp/ssh2/ssh2.c:49:2: warning: initialization of 'const char *' from 'int' makes pointer from integer without a cast [-Wint-conversion]
/tmp/pear/temp/ssh2/ssh2.c:49:2: note: (near initialization for 'php_ssh2_first_arg_force_ref[1].name')
/tmp/pear/temp/ssh2/ssh2.c:49:2: error: initializer element is not constant
/tmp/pear/temp/ssh2/ssh2.c:49:2: note: (near initialization for 'php_ssh2_first_arg_force_ref[1].name')
/tmp/pear/temp/ssh2/ssh2.c: In function 'php_ssh2_debug_cb':
/tmp/pear/temp/ssh2/ssh2.c:103:17: warning: implicit declaration of function 'call_user_function_ex'; did you mean 'call_user_function'? [-Wimplicit-function-declaration]
if (FAILURE == call_user_function_ex(NULL, NULL, data->disconnect_cb, NULL, 3, args, 0, NULL)) {
^~~~~~~~~~~~~~~~~~~~~
call_user_function
/tmp/pear/temp/ssh2/ssh2.c: In function 'zif_ssh2_disconnect':
/tmp/pear/temp/ssh2/ssh2.c:443:6: error: void value not ignored as it ought to be
if (zend_list_close(Z_RES_P(zsession)) != SUCCESS) {
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/tmp/pear/temp/ssh2/ssh2.c:443:41: error: invalid operands to binary != (have 'const zend_internal_arg_info[1]' {aka 'const struct _zend_internal_arg_info[1]'} and 'int')
if (zend_list_close(Z_RES_P(zsession)) != SUCCESS) {
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ^~
 [2021-05-17 10:58 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2021-05-17 10:58 UTC] cmb@php.net
I'm closing this as duplicate of bug #81039.  The code in the
development branch is supposed to be compatible with PHP 8.0.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Dec 05 06:03:37 2021 UTC