php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80417 Upgraded from 7.4.6 to 7.4.12 Cronjobs that call PHP scripts hang indefinitely
Submitted: 2020-11-25 14:27 UTC Modified: 2020-12-03 13:06 UTC
From: mbottos84 at gmail dot com Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 7.4.12 OS: Centos 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mbottos84 at gmail dot com
New email:
PHP Version: OS:

 

 [2020-11-25 14:27 UTC] mbottos84 at gmail dot com
Description:
------------
We used yum update and updated php from the epel repo from 7.4.6 to 7.4.12

Instantly all of our cronjobs that call php were hung.

The server processes don't close and become zombies.
They keep piling up and you can see a process for the php script called and a process for the corresponding crond.

Its possible to manually terminate using kill, but they wont close on their own.
We've tried adding calls to timeout/terminate the php script after several minutes but the process still remains hung.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-11-25 14:30 UTC] nikic@php.net
Just to exclude an issue in 7.4.12 in particular, are you using preloading?
 [2020-11-25 14:49 UTC] danack@php.net
If it's not related to preloading, maybe try ssh'ing into the server and run the script as crond would run it, and check it works like that?

Also, what hosting environment are your servers running in? I've seen some issues with GCP kubernetes where cli scripts were 'hanging' in places where it was 'impossible' for them to hang....
 [2020-11-25 14:55 UTC] mbottos84 at gmail dot com
-: mbottos at membersfirst dot com +: mbottos84 at gmail dot com
 [2020-11-25 14:55 UTC] mbottos84 at gmail dot com
We host our own servers.
If I run the script manually from the terminal, it does not hang. 
Of course, I'm only running it once. The cronjobs run a hundred or two an hour.
It doesn't appear every single one hangs, just the majority.
 [2020-11-25 15:18 UTC] mbottos84 at gmail dot com
Sorry,   No Preloading. 
Was waiting on an answer from the dev.
 [2020-11-25 15:49 UTC] mbottos84 at gmail dot com
Something worth noting, I also updated another identical functioning server that had already been updated to 7.4.11
So that one went from 7.4.11 to 7.4.12

Not sure if this relevant but thought I'd provide any info that I could.

So, 7.4.11 to 7.4.12 was ok
7.4.6 to 7.4.12 produced the issue
 [2020-12-02 20:42 UTC] mbottos84 at gmail dot com
-Status: Open +Status: Closed
 [2020-12-02 20:42 UTC] mbottos84 at gmail dot com
The issue was resolved. My apologies, it appears to be a coincidental in timing issue that was unrelated to php
 [2020-12-03 13:06 UTC] cmb@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Jan 19 13:01:24 2021 UTC