php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80416 Missing dll
Submitted: 2020-11-25 13:48 UTC Modified: 2020-11-25 18:03 UTC
From: tobias at tromm dot no-ip dot org Assigned: cmb (profile)
Status: Not a bug Package: *Configuration Issues
PHP Version: 8.0.0RC5 OS: Windows Server 2008, 2019 (All)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tobias at tromm dot no-ip dot org
New email:
PHP Version: OS:

 

 [2020-11-25 13:48 UTC] tobias at tromm dot no-ip dot org
Description:
------------
Missing dlls

Download page: https://windows.php.net/download/
File: https://windows.php.net/downloads/releases/php-8.0.0-nts-Win32-vs16-x64.zip

[25-Nov-2020 13:24:50 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'php_gd2.dll' (tried: C:\PHP_8_0_0\ext\php_gd2.dll (Não foi possível encontrar o módulo especificado), C:\PHP_8_0_0\ext\php_php_gd2.dll.dll (Não foi possível encontrar o módulo especificado)) in Unknown on line 0
[25-Nov-2020 13:24:50 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'php_xmlrpc.dll' (tried: C:\PHP_8_0_0\ext\php_xmlrpc.dll (Não foi possível encontrar o módulo especificado), C:\PHP_8_0_0\ext\php_php_xmlrpc.dll.dll (Não foi possível encontrar o módulo especificado)) in Unknown on line 0

Expected result:
----------------
Ext dir must contain php_gd2.dll and php_xmlrpc.dll.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-11-25 13:56 UTC] cmb@php.net
-Status: Open +Status: Feedback -Package: Win32API related +Package: *Configuration Issues -Assigned To: +Assigned To: cmb
 [2020-11-25 13:56 UTC] cmb@php.net
xmlrpc has been unbundled[1] and php_gd2.dll has been renamed to
php_gd.dll[2].  So you would have to adjust your php.ini settings.
Does that work for you?

[1] <https://www.php.net/manual/en/migration80.incompatible.php#migration80.incompatible.xmlrpc>
[2] <https://www.php.net/manual/en/migration80.incompatible.php#migration80.incompatible.gd>
 [2020-11-25 17:55 UTC] tobias at tromm dot no-ip dot org
-Status: Feedback +Status: Closed
 [2020-11-25 17:55 UTC] tobias at tromm dot no-ip dot org
Thank you!!

This is because I am using https://github.com/phpmanager/phpmanager to install PHP and the file below must be updated.

https://github.com/phpmanager/phpmanager/blob/d7c1f2aa0c09525d0ddf02c97b1cf05a76014f2c/Server/Config/PHPConfigHelper.cs

I will open one ticket to see if they fix this.
 [2020-11-25 18:03 UTC] cmb@php.net
-Status: Closed +Status: Not a bug
 [2020-11-25 18:03 UTC] cmb@php.net
> I will open one ticket to see if they fix this.

Great!  Thanks!
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 12:05:44 2022 UTC