php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8039 build process doesn't use apxs CFLAGS
Submitted: 2000-11-29 18:10 UTC Modified: 2001-04-27 19:20 UTC
From: cech at debian dot org Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.3pl1 OS: Debian GNU/Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cech at debian dot org
New email:
PHP Version: OS:

 

 [2000-11-29 18:10 UTC] cech at debian dot org
Hi,

I have apache compiled with   -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64

and apxs has this in it's CFLAGS line and also displays it. But

when building php4 with apxs it ignores this and it must be  compiled as

make CFLAGS=" .... " else it crashes apache (as expected).



Petr Cech

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-12-04 08:34 UTC] sniper@php.net
Duplicate of #7211
 [2001-04-27 19:20 UTC] sniper@php.net
This is fixed.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 04:05:54 2022 UTC