php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80343 attempt to connect to Unix domain socket /var/run/php-fpm.sock (*) failed
Submitted: 2020-11-09 15:20 UTC Modified: 2020-12-28 19:51 UTC
From: sainthyoga2003 at gmail dot com Assigned: bukka (profile)
Status: Not a bug Package: FPM related
PHP Version: 7.4.12 OS: openSUSE Tumbleweed
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sainthyoga2003 at gmail dot com
New email:
PHP Version: OS:

 

 [2020-11-09 15:20 UTC] sainthyoga2003 at gmail dot com
Description:
------------
* PHP 7.4.12
* No scripts. 
* Installed via YaST
* Apache 2.4 Server

When I try to start the service via `sudo service php-fpm start` I get this error. No other error is tracked.

I had to reverse the PHP version to 7.4.11

Expected result:
----------------
PHP FPM service started

Actual result:
--------------
attempt to connect to Unix domain socket /var/run/php-fpm.sock (*) failed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-11-09 17:23 UTC] requinix@php.net
-Status: Open +Status: Feedback
 [2020-11-09 17:23 UTC] requinix@php.net
Have you tried any sort of troubleshooting on your own?
 [2020-11-10 16:30 UTC] sainthyoga2003 at gmail dot com
-Status: Feedback +Status: Open
 [2020-11-10 16:30 UTC] sainthyoga2003 at gmail dot com
I think it also is linked with an update in some OS update, because I ran an update unchoosing all PHP packages and I had the same issue.

I also changed the path for the sock file. In this, the file is created the service starts but I get a 503 error.
 [2020-11-11 10:24 UTC] schwarzera at messe-duesseldorf dot de
There is also a bug report at SUSE:

https://bugzilla.opensuse.org/show_bug.cgi?id=1178655
 [2020-11-11 10:34 UTC] nikic@php.net
To double check, as there seems to be some contradictory information: Does downgrading to PHP 7.4.11 fix the issue or not?

If it does fix the issue, i.e. this is a PHP 7.4.12 regression, I would check whether you have the opcache preloading feature enabled, as a regression has been introduced there in PHP 7.4.12.
 [2020-11-11 17:11 UTC] sainthyoga2003 at gmail dot com
@nikic, originally, I was thinking about PHP was affected by the new version (maybe it is one of the issues) but when I tried aonother step, where I do't update the PHP version but I update another packages, I got the same issue. Now, I fixed some permissions issues and the new error is an Access denied. I still don't have a clue if is the OS or if is PHP.

BTW the bug report in openSUSE links this issue XD
 [2020-11-12 07:55 UTC] pgajdos at suse dot com
On my Tumbleweed 20201030-0 , I have updated _just_ php7 to 7.4.12 and the service starts fine with the default configuration.
 [2020-11-13 16:32 UTC] sainthyoga2003 at gmail dot com
AppArmor issue: https://bugzilla.suse.com/show_bug.cgi?id=1178655#c14

Then, isn't related to PHP itself (I think).
 [2020-12-28 19:51 UTC] bukka@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: bukka
 [2020-12-28 19:51 UTC] bukka@php.net
Closing as per the last comment from the OP. If you think that's not AppArmor issue at the end, please comment here.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Jan 27 00:01:24 2021 UTC