php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #80331 Change in error level not listed in Migration guide
Submitted: 2020-11-06 19:13 UTC Modified: 2020-11-06 19:54 UTC
From: php4fan at gmail dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 7.4.12 OS: all
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php4fan at gmail dot com
New email:
PHP Version: OS:

 

 [2020-11-06 19:13 UTC] php4fan at gmail dot com
Description:
------------
---
From manual page: https://php.net/migration70.incompatible
---

The error level for use of undefined constants was changed from NOTICE to WARNING in PHP 7.

This should be mentioned somewhere at https://www.php.net/manual/en/migration70.incompatible.php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-11-06 19:53 UTC] salathe@php.net
-Status: Open +Status: Not a bug
 [2020-11-06 19:53 UTC] salathe@php.net
The change from notice to warning was in PHP 7.2, and is present in that migration guide.

https://www.php.net/manual/en/migration72.incompatible.php#migration72.incompatible.undefined-constants
 [2020-11-06 19:54 UTC] requinix@php.net
Ooh, so close.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jul 30 18:01:30 2021 UTC