php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80253 Community PHP does nothing on IBM i 7.4
Submitted: 2020-10-18 03:47 UTC Modified: 2020-10-18 05:50 UTC
From: softwoehr at gmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 7.3.23 OS: IBM i 7.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: softwoehr at gmail dot com
New email:
PHP Version: OS:

 

 [2020-10-18 03:47 UTC] softwoehr at gmail dot com
Description:
------------
After installing community edition for IBM i ppc64 from Zend repo via yum, (software is installed, but does not operate correctly.
- yum install 'php*' from http://repos.zend.com/ibmiphp/
- follow instructions on https://odbcphp.k3s.com/ and copy /QOpenSys/etc/php.ini to /QOpenSys/etc/php/php.ini
- Check all the modules are mentioned in /QOpenSys/etc/php/conf.d
- Try it out
 
NOTE that the version offered from Zend repo is as follows:
$ php --version
PHP 7.3.14 (cli) (built: Jan 30 2020 07:25:43) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.14, Copyright (c) 1998-2018 Zend Technologies


Test script:
---------------
Sample session:

driveway@Common1:~$ chroot /QOpenSys/jwoehr
driveway@Common1:/$ php -a
Interactive mode enabled

echo "foo";
echo "foo";
driveway@Common1:~$ chroot /QOpenSys/jwoehr
driveway@Common1:/$ echo 'echo "foo";' | php
echo "foo";
driveway@Common1:/$ 

Expected result:
----------------
Expect conventional php interactive behavior.

Actual result:
--------------
Does not hang, but does not operate.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-10-18 03:53 UTC] rtrtrtrtrt at dfdfdfdf dot dfd
"php -m" is pretty sure missing "readline" extension
 [2020-10-18 04:08 UTC] requinix@php.net
-Status: Open +Status: Feedback -Package: Output Control +Package: *General Issues
 [2020-10-18 04:08 UTC] requinix@php.net
Install the readline extension.

> driveway@Common1:/$ echo 'echo "foo";' | php
> echo "foo";
Input from stdin is not PHP code like it is in -a mode. You need a <?php.
 [2020-10-18 04:47 UTC] softwoehr at gmail dot com
-Status: Feedback +Status: Open
 [2020-10-18 04:47 UTC] softwoehr at gmail dot com
Yes, you're right, d'oh,

 echo '<?php echo "foo";' | php 

works.

and php -m doesn't reveal a readline module
 [2020-10-18 04:57 UTC] requinix@php.net
-Status: Open +Status: Feedback
 [2020-10-18 04:57 UTC] requinix@php.net
Install the readline extension.
 [2020-10-18 05:40 UTC] softwoehr at gmail dot com
-Status: Feedback +Status: Open
 [2020-10-18 05:40 UTC] softwoehr at gmail dot com
Thanks, works for me.
 [2020-10-18 05:41 UTC] softwoehr at gmail dot com
-Status: Open +Status: Closed
 [2020-10-18 05:41 UTC] softwoehr at gmail dot com
Zend installation works with readline module from qseco.fr
 [2020-10-18 05:50 UTC] requinix@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Apr 11 03:01:23 2021 UTC