php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80200 On reply to nikic on https://bugs.php.net/bug.php?id=80199
Submitted: 2020-10-07 18:31 UTC Modified: 2020-10-07 23:51 UTC
From: gilperon at gmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 7.4.11 OS: all
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gilperon at gmail dot com
New email:
PHP Version: OS:

 

 [2020-10-07 18:31 UTC] gilperon at gmail dot com
Description:
------------
[2020-10-07 18:25 UTC] nikic@php.net

This is such a well known open problem that I really don't need to run your code to identify it :)



Great nikic! Let's get this well known open problem more visibility by not getting it fixed! That's why for most time recently I am using Golang, MUCH better implementation and community support. 

I think you believe I will get any money by coming here reporting a bug. No, I dont get anything, I just waste my time, as all the previous attempts I made. kkk Keep doing it like this, even Microsoft wont support PHP binaeries from 8.x and later. 

Test script:
---------------
stuck your finger on your ars

Expected result:
----------------
shit should come out

Actual result:
--------------
a fart

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-10-07 18:35 UTC] great at gmail dot com
-: gilperon at gmail dot com +: great at gmail dot com
 [2020-10-07 18:35 UTC] great at gmail dot com
Great!
 [2020-10-07 18:38 UTC] nikic@php.net
-Status: Open +Status: Not a bug
 [2020-10-07 18:38 UTC] nikic@php.net
Marking your report as a duplicate does not mean that it will not be addressed, only that there is an existing report tracking this issue already. Having multiple open bugs for the same root cause is counter-productive, as information gets spread out.

Unfortunately the issue in question is simply not easy to fix. My last attempt at it was https://github.com/php/php-src/pull/5595, which would address your particular case of eval'd closures, but does not fully generalize to the case of anonymous classes.
 [2020-10-07 19:27 UTC] gilperon at gmail dot com
-: great at gmail dot com +: gilperon at gmail dot com
 [2020-10-07 19:27 UTC] gilperon at gmail dot com
nikic@php.net I am sorry for my behaviour but I was pissed of because most of the times I report something here, I really waste my time. And I work for living, not for hobby. When I come here to report a bug, I am donating some of my time trying to help the community - I will not get anything from the bug being fixed or not because I always need a solution immediatly, so I always end up having to find a workaround the bug.

Just as a side not: I reported this bug on SO at https://stackoverflow.com/questions/64249929/why-using-eval-will-not-release-memory-later-when-using-unset-on-anonymous-f and a guy name NIGEL REN gave me a nice solution! Instead of evaluating the function code I should put it inside a file and `require` the file.

Amazingly enough, he, me and other guy on that thread realized that PHP does not clear it's memory footprint on files included/required! That's a pretty big problem, I  abuse" the use of `require` in lots of my projects and I never knew that using require/include would not clear RAM! That's pretty terrible and explains a lot why most of the cloud servers I manage use so much RAM because I use a TON require to keep our codebase organized.
 [2020-10-07 23:41 UTC] girgias@php.net
And most people who work on PHP do this actually as a hobby and do not get paid.

So the minimum is to be polite.
 [2020-10-07 23:51 UTC] gilperon at gmail dot com
@girgias@php.net I couldnt care less for people that fork PHP and do it as a hobby. What I do as my hobby is not your business, and what you do on your spare time, is not my business. I will not be glad to you that your hobby is A, B or C. As I dont expect at all that you will be glad if my hobby is forking PHP and solving bugs. 

I dont know if you have any idea of what is a hobby, but generally a hobby is something where you put your time, effort, money... into and expect nothing but happines, inner peace... If you expect money from a hobby, it's a job. If you expect people praising your name, thanking you for your hobby, it's not a job, it's selfishness and peacockery.
 [2020-10-07 23:55 UTC] rtrtrtrtrt at dfdfdfdf dot dfd
gilperon at gmail dot com: you don't get it!

most of the developers are not paid, that's it, no tmore and not less
compared to other programming languages PHP has envolvd a lot in the past few years *without* breaking changes, period
 [2020-10-08 02:48 UTC] gilepron at gmail dot com
rtrtrtrtrt at dfdfdfdf dot dfd OF COURSE I know people are not being paid here. Of course I know that. But if you have spare time to maintain PHP source code as your hobby, you shouldnt expect people to pray for you. I also dont exepct people to pray for me when I waste my time coming here, reporting a bug, creating a test case... nobody comes to me and say "thank you, you are a great person for reporting this bug, take here $ 1 for your time". Both sides are doing their best to the project, wheter reporting of fixing bugs.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 01:05:44 2022 UTC