php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80170 incorrect floating
Submitted: 2020-10-01 18:12 UTC Modified: 2020-10-02 08:32 UTC
From: wapinet at mail dot ru Assigned:
Status: Not a bug Package: Math related
PHP Version: 8.0.0beta4 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: wapinet at mail dot ru
New email:
PHP Version: OS:

 

 [2020-10-01 18:12 UTC] wapinet at mail dot ru
Description:
------------
https://3v4l.org/X4I7W

Test script:
---------------
<?php
var_dump(34.99 - 10);

// Output for 8.0.0alpha1 - beta4
//     float(24.990000000000002)
// Output for 7.2.0 - 7.2.34, 7.3.0 - 7.3.23, 7.4.0 - 7.4.11
//     float(24.99)


Expected result:
----------------
24.99

Actual result:
--------------
24.990000000000002

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-10-01 18:41 UTC] girgias@php.net
-Status: Open +Status: Not a bug
 [2020-10-01 18:41 UTC] girgias@php.net
Floating point values have a limited precision. Hence a value might
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.


 [2020-10-01 21:03 UTC] wapinet at mail dot ru
i think it mentions to this note https://github.com/php/php-src/blob/php-8.0.0rc1/UPGRADING#L565
and in real life we actually have usually string "24.99" - https://3v4l.org/44JT1
 [2020-10-02 08:32 UTC] nikic@php.net
@wapinet at mail dot ru: Could you please clarify what the bug here is supposed to be? You are right that 24.99 is the more useful representation for end-users ... and they will still get it, because that's the formatting you'll see if you cast the number to string, print it with "echo" etc. This change only affects the output of var_dump(), which is a debugging function, where it is important to see the exact result.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Apr 13 07:01:24 2021 UTC