php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80144 if you go to do the sum is 0, but php returns 3.3306690738755E-15. Why?
Submitted: 2020-09-24 08:43 UTC Modified: 2020-09-24 08:49 UTC
From: daniel dot maoloni at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: *Math Functions
PHP Version: 7.4.10 OS: Windows 10 Pro - XAMMP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: daniel dot maoloni at gmail dot com
New email:
PHP Version: OS:

 

 [2020-09-24 08:43 UTC] daniel dot maoloni at gmail dot com
Description:
------------
$a=33.460000;
$b=-34.870000;
$c=1.410000;

echo $a+$b+$c;

result PHP : 3.3306690738755E-15

if you go to do the sum is 0, but php returns 3.3306690738755E-15. Why?

thank you


Test script:
---------------
$a=33.460000;
$b=-34.870000;
$c=1.410000;

echo $a+$b+$c;



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-09-24 08:49 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2020-09-24 08:49 UTC] cmb@php.net
Floating point values have a limited precision. Hence a value might
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jan 24 10:01:24 2021 UTC