php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80134 compile failure
Submitted: 2020-09-22 15:47 UTC Modified: 2020-09-23 02:47 UTC
From: 823688826 at qq dot com Assigned: cmb (profile)
Status: Not a bug Package: Compile Failure
PHP Version: 7.3Git-2020-09-22 (Git) OS: ubuntu
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: 823688826 at qq dot com
New email:
PHP Version: OS:

 

 [2020-09-22 15:47 UTC] 823688826 at qq dot com
Description:
------------
php version 7.3.6
checking for GD support... yes
checking for the location of libwebp... no
checking for the location of libjpeg... yes
checking for the location of libpng... yes
checking for the location of libXpm... shared
checking for FreeType 2... yes
checking whether to enable JIS-mapped Japanese font support in GD... no
If configure fails try --with-webp-dir=<DIR>
checking for jpeg_read_header in -ljpeg... yes
checking for png_write_image in -lpng... yes
checking for XpmFreeXpmImage in -lXpm... yes
configure: error: freetype-config not found.


Test script:
---------------
./configure --prefix=/opt/php7.3 --with-config-file-path=/opt/php7.3/etc --with-config-file-scan-dir=/opt/php7.3/etc.d --enable-fpm --disable-ipv6 --with-libxml-dir --with-openssl=/opt/openssl/ --with-pcre-regex --with-zlib --enable-bcmath --with-bz2 --enable-calendar --with-curl=shared --enable-dba=shared --enable-exif=shared --with-gd --with-jpeg-dir --with-png-dir --with-zlib-dir --with-xpm-dir=shared --with-freetype-dir --with-gettext --with-mhash --with-kerberos --enable-mbstring --with-mysqli=mysqlnd --enable-opcache --enable-pcntl --with-pdo-mysql=mysqlnd --with-readline --enable-shmop --enable-soap --enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm --enable-zip --enable-mysqlnd --enable-maintainer-zts


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-09-22 15:54 UTC] danack@php.net
"configure: error: freetype-config not found."

It's looking for freetype-config and not finding it.
 [2020-09-22 16:33 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2020-09-22 16:33 UTC] cmb@php.net
Prior to PHP 7.4.0, building ext/gd with the bundled libgd
requires freetype-config.  If you're using a new version of
libfreetype, freetype-config may be missing.  In this case you
have the following options:

* build without freetype support: --without-freetype-dir
* build ext/gd against an external libgd: --with-gd=/path/to/libgd
* use a libfreetype which ships freetype-config
* patch ext/gd/config.m4 according to your needs
* use PHP 7.4
 [2020-09-23 02:38 UTC] 823688826 at qq dot com
-Status: Not a bug +Status: 不是错误
 [2020-09-23 02:38 UTC] 823688826 at qq dot com
ok, thank you
 [2020-09-23 02:47 UTC] requinix@php.net
-Status: ???? +Status: Not a bug
 [2020-09-23 02:47 UTC] requinix@php.net
.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun May 16 19:01:23 2021 UTC