php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #80091 Missing getName documentation
Submitted: 2020-09-11 09:03 UTC Modified: 2020-09-12 10:30 UTC
From: rh at hrdns dot de Assigned: cmb (profile)
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS: any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rh at hrdns dot de
New email:
PHP Version: OS:

 

 [2020-09-11 09:03 UTC] rh at hrdns dot de
Description:
------------
---
From manual page: https://php.net/class.reflectiontype
---

public getName ( void ) : string

documentation is missing

Test script:
---------------
<?php
echo "no";

Expected result:
----------------
no

Actual result:
--------------
no

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-09-11 09:13 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2020-09-11 09:13 UTC] cmb@php.net
There is no ReflectionType::getName().  Are you looking for
ReflectionNamedType::getName()[1]?

[1] <https://www.php.net/manual/en/reflectionnamedtype.getname.php>
 [2020-09-11 18:58 UTC] rh at hrdns dot de
OH! SRY my mistake!
 [2020-09-12 10:30 UTC] cmb@php.net
-Status: Feedback +Status: Not a bug
 [2020-09-12 10:30 UTC] cmb@php.net
No problem.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Nov 27 10:01:23 2020 UTC