php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #80035 Mistake in explaining function operation
Submitted: 2020-08-30 13:24 UTC Modified: 2020-08-30 14:20 UTC
From: victor dot dorado dot asensio at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: victor dot dorado dot asensio at gmail dot com
New email:
PHP Version: OS:

 

 [2020-08-30 13:24 UTC] victor dot dorado dot asensio at gmail dot com
Description:
------------
---
From manual page: https://php.net/function.array-intersect-assoc
---

I think the correct phrase would be "Note that **the values** are also used in the comparison unlike in array_intersect()."

("the values" instead of "the keys")


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-08-30 14:20 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2020-08-30 14:20 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

array_intersect() uses the values; array_intersect_assoc() also uses the keys.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jan 17 20:01:23 2021 UTC