php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8003 Document contained no data
Submitted: 2000-11-28 01:49 UTC Modified: 2000-12-30 19:40 UTC
From: jfong at 2link dot net Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.3pl1 OS: RH6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jfong at 2link dot net
New email:
PHP Version: OS:

 

 [2000-11-28 01:49 UTC] jfong at 2link dot net
GNU gdb 4.18
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(gdb) run -X -f /export/apache-1.3.9/conf/httpd-33.conf
Starting program: /export/apache-1.3.9/bin/httpd -X -f /export/apache-1.3.9/conf/httpd-33.conf
chiliasp: module started, version 3.5.2.31
 
Program received signal SIGSEGV, Segmentation fault.
0x4034f17e in php_fopen_url_wrap_ftp (
    path=0x8166948 "P\020\025\b\030?\024\bx \r\b", mode=0x40281f8c "?\037", 
    options=500, issock=0x9, socketd=0x0, opened_path=0x8103890)
    at fopen-wrappers.c:669
669                     } else {
(gdb) bt
#0  0x4034f17e in php_fopen_url_wrap_ftp (
    path=0x8166948 "P\020\025\b\030?\024\bx \r\b", mode=0x40281f8c "?\037", 
    options=500, issock=0x9, socketd=0x0, opened_path=0x8103890)
    at fopen-wrappers.c:669
#1  0x4034f15c in php_fopen_url_wrap_ftp (
    path=0x8166948 "P\020\025\b\030?\024\bx \r\b", mode=0x40281f8c "?\037", 
    options=500, issock=0x9, socketd=0x0, opened_path=0x8103890)
    at fopen-wrappers.c:668
#2  0x8055833 in ap_invoke_handler ()
#3  0x8068fb9 in process_request_internal ()
#4  0x80693e8 in ap_internal_redirect ()
#5  0x40280c52 in ?? () from /export/apache-1.3.9/libexec/mod_dir.so
#6  0x8055833 in ap_invoke_handler ()
#7  0x8068fb9 in process_request_internal ()
#8  0x806901c in ap_process_request ()
#9  0x806091e in child_main ()
#10 0x8060acc in make_child ()
#11 0x8060c29 in startup_children ()
#12 0x8061256 in standalone_main ()
#13 0x80619e9 in main ()
#14 0x4007b1eb in __libc_start_main (main=0x806169c <main>, argc=4, 
    argv=0xbffffcc4, init=0x804f928 <_init>, fini=0x809889c <_fini>, 
    rtld_fini=0x4000a610 <_dl_fini>, stack_end=0xbffffcbc)
---Type <return> to continue, or q <return> to quit---
    at ../sysdeps/generic/libc-start.c:90


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-28 05:17 UTC] sniper@php.net
This is kinda useless if you don't give any info
in what circumstances this happened? 
Was it on startup? Or was it with some script?
If latter, please include short script which
can be used to reproduce this.

--Jani
 [2000-12-30 19:40 UTC] sniper@php.net
No feedback. Can't reproduce without sample script.

--Jani
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed May 22 19:01:31 2024 UTC