php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #80004 Integrated PAM support in PHP 8
Submitted: 2020-08-21 06:07 UTC Modified: 2020-08-21 13:58 UTC
Votes:35
Avg. Score:4.8 ± 0.8
Reproduced:19 of 21 (90.5%)
Same Version:18 (94.7%)
Same OS:16 (84.2%)
From: volker dot theile at openmediavault dot org Assigned:
Status: Suspended Package: PAM (PECL)
PHP Version: Next Major Version OS: Ubuntu 20.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: volker dot theile at openmediavault dot org
New email:
PHP Version: OS:

 

 [2020-08-21 06:07 UTC] volker dot theile at openmediavault dot org
Description:
------------
Please integrate PAM support into PHP 8. With PHP 7 it is already a pain to use the pluggable authentication system because the PECL extension is not maintained anymore. I fear that with PHP 8 the extension and available patch files will become unusable. Please consider to fully integrate PAM into the origin source tree to allow developers to use this really needed feature. Otherwise i think PHP 8 will become only a toy that can't be used for professional applications anymore.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-08-21 08:06 UTC] cmb@php.net
-Status: Open +Status: Suspended
 [2020-08-21 08:06 UTC] cmb@php.net
Well, it should be the other way round: there is this generally
useful and well maintained PECL package; shouldn't we bundle it?

Anyhow, this feature request requires discussion which is beyond
the scope of this bug tracker.  Please send mail to the internals
mailing list[1].  I'm suspending this ticket for the time being.

[1] <https://www.php.net/mailing-lists.php#internals>
 [2020-08-21 13:58 UTC] volker dot theile at openmediavault dot org
> there is this generally useful and well maintained PECL package; shouldn't we bundle it?

You are talking about https://pecl.php.net/package/PAM? This is not maintained since ages and can not be used anymore since PHP7, i don't expect it will work with PHP8 then. To get it working with PHP7 you need to patch it, see https://github.com/openmediavault/openmediavault/blob/master/deb/php-pam/debian/patches/01-php7.patch (patch was done by Mikael Johansson).

> Anyhow, this feature request requires discussion which is beyond
the scope of this bug tracker.

Will do so, thanks.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Nov 25 08:01:23 2020 UTC