php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79990 glob() returns duplicate values
Submitted: 2020-08-18 14:58 UTC Modified: 2020-08-18 15:19 UTC
From: bonzura at yahoo dot co dot jp Assigned: cmb (profile)
Status: Duplicate Package: Filesystem function related
PHP Version: 7.4.9 OS: Windows10
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: bonzura at yahoo dot co dot jp
New email:
PHP Version: OS:

 

 [2020-08-18 14:58 UTC] bonzura at yahoo dot co dot jp
Description:
------------
glob() returns duplicate values ​​when the number of files is 65534 or more.

It occurs only in Windows PHP ver 7.4.9 or earlier, not in 8.0 or Linux.

When number of files increase, duplicate values also increase.

When I tried Test script $max=1000000, result is below.
--------
1000015
Duplicated test/0000065534.txt->2
Duplicated test/0000131069.txt->2
Duplicated test/0000196604.txt->2
Duplicated test/0000262139.txt->2
Duplicated test/0000327674.txt->2
Duplicated test/0000393209.txt->2
Duplicated test/0000458744.txt->2
Duplicated test/0000524279.txt->2
Duplicated test/0000589814.txt->2
Duplicated test/0000655349.txt->2
Duplicated test/0000720884.txt->2
Duplicated test/0000786419.txt->2
Duplicated test/0000851954.txt->2
Duplicated test/0000917489.txt->2
Duplicated test/0000983024.txt->2


Test script:
---------------
<?php
$max=65534;
$dir='test/';
for ($i=1;$i<=$max;$i++){
    file_put_contents($dir.sprintf("%010d",$i).".txt",$i);
}

$files=glob($dir."*");
echo count($files)."\n";

$check=array_count_values($files);
foreach ($check as $key=>$value){
	if ($value!=1){
		echo "Duplicated ".$key."->".$value."\n";
	}
}
?>

Expected result:
----------------
65534

Actual result:
--------------
65535
Duplicated test/0000065534.txt->2

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-08-18 15:19 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2020-08-18 15:19 UTC] cmb@php.net
This is a duplicate of bug #36365.  The fix for that bug cannot be
backported, because it breaks the ABI.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jun 13 19:01:24 2021 UTC