php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79904 printf() and sprintf() not proper formatted string.
Submitted: 2020-07-28 04:35 UTC Modified: 2020-07-28 04:40 UTC
From: amit000790 at gmail dot com Assigned:
Status: Not a bug Package: Strings related
PHP Version: 7.4.8 OS: ubuntu LTS 20.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: amit000790 at gmail dot com
New email:
PHP Version: OS:

 

 [2020-07-28 04:35 UTC] amit000790 at gmail dot com
Description:
------------
- when I used % sign in a string, as a result after the first-word letter skipped.

Test script:
---------------
printf(
    '12.5% tax price: %1$s',
    '1200'
);


Expected result:
----------------
12.5% tax price: 1200

Actual result:
--------------
12.5ax price: 1200

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-07-28 04:40 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2020-07-28 04:40 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

If you want a literal percent sign then you have to escape it as %%.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 01 10:03:45 2023 UTC