php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79861 bug found in php 5.3, 5.4. 7.0, 7.1, 7.2
Submitted: 2020-07-14 19:35 UTC Modified: 2020-07-14 19:39 UTC
From: BardoQi at gmail dot com Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 7.2.32 OS: windwos 10, contos7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: BardoQi at gmail dot com
New email:
PHP Version: OS:

 

 [2020-07-14 19:35 UTC] BardoQi at gmail dot com
Description:
------------
The return value of expression /(4.1-0.1 == 4.0)/ should be true, but infact false!!

Test script:
---------------
		echo(4.1-0.1 == 4.0);
		echo(4.1-0.1 == 4);
		echo((4.1-0.1) == 4.0);
		echo((4.1-0.1) == 4);

Expected result:
----------------
1111


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-07-14 19:39 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2020-07-14 19:39 UTC] requinix@php.net
Floating point values have a limited precision. Hence a value might
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 25 10:03:33 2022 UTC