php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79833 Assertion `0' failed in decrement_function
Submitted: 2020-07-11 06:19 UTC Modified: 2020-07-11 07:57 UTC
From: changochen1 at gmail dot com Assigned:
Status: Duplicate Package: Scripting Engine problem
PHP Version: 8.0Git-2020-07-11 (Git) OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: changochen1 at gmail dot com
New email:
PHP Version: OS:

 

 [2020-07-11 06:19 UTC] changochen1 at gmail dot com
Description:
------------
LOG:
---
php: /home/yongheng/php_clean/Zend/zend_operators.c:2442: int decrement_function(zval *): Assertion `0' failed.
---

Test script:
---------------
<?
ob_start ( function () { array_pop ( $GLOBALS ) ; } , 20 );
$a -- ;


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-07-11 07:57 UTC] twosee@php.net
-Status: Open +Status: Duplicate
 [2020-07-11 07:57 UTC] twosee@php.net
Duplicate of #79831, the same problem
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Sep 30 07:01:23 2020 UTC