php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7969 ibase_prepare() and ibase_execute() don't work
Submitted: 2000-11-25 10:45 UTC Modified: 2000-11-28 00:43 UTC
From: kerdos at kerdos dot it Assigned:
Status: Closed Package: InterBase related
PHP Version: 4.0.3pl1 OS: Linux Mandrake 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kerdos at kerdos dot it
New email:
PHP Version: OS:

 

 [2000-11-25 10:45 UTC] kerdos at kerdos dot it
In PHP 4.0.2 and 4.0.3pl1 the example presented in the manual about ibase_prepare() and ibase_execute() functions doesn't work at all. The script stops executing at ibase_execute() function call doing nothing on the database.
The problem is not present with PHP 4.0.0. This affects the possibility of using blob functions with interbase.

PHP 4.0.0 working version was compiled with the following options:

 ./configure --prefix=/usr --with-apxs --libdir=/usr/lib/php4 --includedir=/usr/include --datadir=/usr/share/php --with-config-file-path=/etc/httpd --with-interbase=/opt/interbase

The test script was:

<?php

echo "<HTML><body>";
echo "inizio<br>";

$conn=ibase_connect("localhost:/opt/interbase/prova.gdb","SYSDBA","masterkey");
  $updates = array(
  	1 => 'Eric',
  	5 => 'Filip',
  	7 => 'Larry'
  );

  $query = ibase_prepare("UPDATE FOO SET BAR = ? WHERE BAZ = ?");

  while (list($baz, $bar) = each($updates)) {
  	echo "non fatto<br>";
  	flush();
  	ibase_execute($query, $bar, $baz);
   	echo "fatto<br>";
  	flush();
  }
  ibase_commit();

echo "fine";
echo "</body></html>";
?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-27 08:00 UTC] jah@php.net
Fixed in current CVS.
 [2000-11-28 00:43 UTC] kerdos at kerdos dot it
I've just seen that there ware already several bug reports similar to mine...i hope you will forgive me for the unuseful report

Riccardo Marchetti
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 22:03:36 2021 UTC