php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79678 Build fails due to undeclared ZIP_RDONLY
Submitted: 2020-06-06 10:07 UTC Modified: 2020-06-06 10:42 UTC
From: rk at srsbiz dot pl Assigned: remi (profile)
Status: Closed Package: Zip Related
PHP Version: master-Git-2020-06-06 (Git) OS: linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: rk at srsbiz dot pl
New email:
PHP Version: OS:

 

 [2020-06-06 10:07 UTC] rk at srsbiz dot pl
Description:
------------
Trying to compile from source (revision aa9b0cc) with libzip 0.11.2 (minimal required)

/usr/src/php-master/ext/zip/php_zip.c: In function ‘zim_ZipArchive_open’:
/usr/src/php-master/ext/zip/php_zip.c:1459:31: error: ‘ZIP_RDONLY’ undeclared (first use in this function)





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-06-06 10:37 UTC] requinix@php.net
-Status: Open +Status: Verified -Package: Compile Failure +Package: Zip Related
 [2020-06-06 10:42 UTC] cmb@php.net
-Assigned To: +Assigned To: remi
 [2020-06-06 10:42 UTC] cmb@php.net
We should likely either reinstate that guard, or lift the
requirements for master.

[1] <https://github.com/php/php-src/blob/php-7.4.6/ext/zip/php_zip.c#L1476-L1489>
 [2020-06-07 05:34 UTC] remi@php.net
We have to re-add a guard, but only for ZIP_RDONLY as we want the deprecation message with all libzip version
 [2020-06-07 05:53 UTC] remi@php.net
Automatic comment on behalf of remi
Revision: http://git.php.net/?p=php-src.git;a=commit;h=a3bfd4a1082f00eecde9c1feddbdb8adf4a928da
Log: Fixed bug #79678 Build fails due to undeclared ZIP_RDONLY
 [2020-06-07 05:53 UTC] remi@php.net
-Status: Verified +Status: Closed
 [2020-06-07 06:00 UTC] remi@php.net
@cmb indeed, we probably have to raise minimal supported libzip... 

- 1.0.0 from 2015 for RD_ONLY and error management ?
- 1.2.0 from 2017 for encryption ?
- 1.3.1 from 2017 for version reporting ?

BTW, seems some people still use some damned old version...
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 23 12:03:33 2022 UTC