php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #79606 Doc Bulid problem
Submitted: 2020-05-16 10:24 UTC Modified: 2020-05-16 10:57 UTC
From: 1274364665 at qq dot com Assigned: cmb (profile)
Status: Not a bug Package: Documentation problem
PHP Version: 7.4.6 OS: MAC OS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: 1274364665 at qq dot com
New email:
PHP Version: OS:

 

 [2020-05-16 10:24 UTC] 1274364665 at qq dot com
Description:
------------
---
https://www.php.net/manual/en/language.types.array.php
---
in the php docment  about Arrays it is said "Converting NULL to an array results in an empty array." this is absolutely wrong .in fact if execute array(NULL),the result is not an empty array the array key will be 0 the array value will be NULL

Test script:
---------------
public function arrTest(){
    $a   = NULL;
    $arr = array($a);
    foreach ($arr as $key => $value) {
        var_dump($key);    // 0
        var_dump($value);  // NULL
    }
    var_dump(count($arr)); // 1
    exit;
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-05-16 10:57 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Package: Doc Build problem +Package: Documentation problem -Assigned To: +Assigned To: cmb
 [2020-05-16 10:57 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

array() does not convert to array, but rather constructs an array.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Aug 09 17:01:23 2020 UTC