php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79559 TLS connections timing-out on 7.4 (all versions after 7.3.17)
Submitted: 2020-05-02 23:06 UTC Modified: 2020-05-03 12:46 UTC
From: imnieves at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: *Encryption and hash functions
PHP Version: 7.4.5 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: imnieves at gmail dot com
New email:
PHP Version: OS:

 

 [2020-05-02 23:06 UTC] imnieves at gmail dot com
Description:
------------
Several users of phpredis (a PHP interface to Redis) have noticed (in php from 7.4.0 and onwards) that TLS connections to Redis time out.  When we establish non-TLS connections to Redis (using the same phpredis), we experience no timeout.

I have personally verified the issue exists on all versions of 7.4 from 7.4.0 to 7.4.5, and that the issue does not exists on version 7.3.17



Test script:
---------------
The test script is longer than 20 lines, so here is a link:
https://github.com/phpredis/phpredis/issues/1726

Here you can find the script, its output, log trace, and explanation of test setup.

Expected result:
----------------
The expectation is that TLS connections are either established or not in a consistent amount of time, but not seemingly randomly timing out (taking a large amount of time to fail).

Actual result:
--------------
The actual result is that TLS connections are being established in an inconsistent amount of time.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-05-03 12:46 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2020-05-03 12:46 UTC] cmb@php.net
This is a duplicate of bug #79501.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 26 06:01:23 2020 UTC