php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79534 Duplicate Mimetype
Submitted: 2020-04-28 21:23 UTC Modified: 2020-04-28 23:33 UTC
From: grussellmd at gmail dot com Assigned:
Status: Duplicate Package: *General Issues
PHP Version: 7.4.5 OS: Linux Debian
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: grussellmd at gmail dot com
New email:
PHP Version: OS:

 

 [2020-04-28 21:23 UTC] grussellmd at gmail dot com
Description:
------------
At least for one mime type I get the wrong format, it's duplicated


Test script:
---------------
$finfo = new \finfo(FILEINFO_MIME_TYPE, null);
echo  $finfo->file('/var/www/html/t2.xlsx');

Expected result:
----------------
application/vnd.openxmlformats-officedocument.spreadsheetml.sheet

Actual result:
--------------
application/vnd.openxmlformats-officedocument.spreadsheetml.sheetapplication/vnd.openxmlformats-officedocument.spreadsheetml.sheet

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-04-28 21:37 UTC] grussellmd at gmail dot com
File was created using LibreOffice in Ubuntu and saved as xlsx Excel Spreadsheet
 [2020-04-28 23:33 UTC] requinix@php.net
-Status: Open +Status: Duplicate
 [2020-04-28 23:33 UTC] requinix@php.net
Duplicate of bug #77784
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu May 13 04:01:23 2021 UTC