php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #79502 trouble sqlite
Submitted: 2020-04-21 08:28 UTC Modified: 2020-04-21 08:34 UTC
From: eca dot mbc at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: SQLite related
PHP Version: 7.4.5 OS: windows x64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
36 - 4 = ?
Subscribe to this entry?

 
 [2020-04-21 08:28 UTC] eca dot mbc at gmail dot com
Description:
------------
in php 7.4.5:
sqlite don't work whith kanboard
when open, i'have message:
PHP extension required: "pdo_sqlite"

i saw files size =
php_pdo_sqlite = 28 672
php_sqlite3_dll = 46 080

in php 7.2.30:
all works!

i saw files size
php_pdo_sqlite = 883 200
php_sqlite3_dll = 814 592

have a good day


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-04-21 08:33 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2020-04-21 08:33 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Make sure that sqlite3.dll is in the PATH.
 [2020-04-21 08:34 UTC] cmb@php.net
Actually, libsqlite3.dll has to be in the PATH.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jun 19 16:01:33 2024 UTC