php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #79456 Imagick PECL extension Requirements docs incomplete
Submitted: 2020-04-07 16:45 UTC Modified: 2020-04-07 22:28 UTC
From: teo8976 at gmail dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS: debian
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: teo8976 at gmail dot com
New email:
PHP Version: OS:

 

 [2020-04-07 16:45 UTC] teo8976 at gmail dot com
Description:
------------
---
From manual page: https://php.net/imagick.requirements
---

The ONE thing I expect from this page is to tell me what are the requirements in order to install this pecl extension.

It says "PHP >= 5.1.3 and ImageMagick >= 6.2.4 is required.", hence I should be able to assume that, if I have those, I have all that is needed.

Not so.

I followed the generic installation instructions at https://www.php.net/manual/en/install.pecl.phpize.php and I got the error:

error: not found. Please provide a path to MagickWand-config or Wand-config program.

I had to google it to find out the answer on serverfault.com that I needed to install these:

sudo apt-get install libmagickwand-dev libmagickcore-dev

This should have been in the Requirements page.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-04-07 22:28 UTC] girgias@php.net
-Status: Open +Status: Not a bug
 [2020-04-07 22:28 UTC] girgias@php.net
You tried to compile the extension and not install it, therefore needing the dev packages is expected.
A command to install this extension on Ubuntu using the APT package manager would be:

sudo apt-get install php-imagick

which will install the extension.
We cannot provided instruction for how to install extensions as it depends by distribution.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 19 10:01:24 2020 UTC