php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79374 German Letter ẞ
Submitted: 2020-03-12 19:18 UTC Modified: 2020-03-12 19:26 UTC
From: info at daniel-marschall dot de Assigned:
Status: Not a bug Package: *Unicode Issues
PHP Version: 7.4.3 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: info at daniel-marschall dot de
New email:
PHP Version: OS:

 

 [2020-03-12 19:18 UTC] info at daniel-marschall dot de
Description:
------------
In reply to the change migration73.new-features

I think the German code folding is not correct
Changing Straße into STRASSE is not wrong,
but actually it would be better to use the character ẞ (which is the upper case of ß)
so more correct would be
STRAẞE

see more information here https://de.wikipedia.org/wiki/%C3%9F


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-03-12 19:26 UTC] nikic@php.net
-Status: Open +Status: Not a bug
 [2020-03-12 19:26 UTC] nikic@php.net
Case mapping behavior is specified by Unicode. If you would like the normative case mapping behavior to be changed, you will have to take to take this up with the Unicode consortium.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 03:03:16 2021 UTC