php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #79361 Failure to mention BC breaking changes due PCRE2 upgrade
Submitted: 2020-03-09 18:27 UTC Modified: 2020-05-17 15:50 UTC
From: jakob at givoni dot dk Assigned:
Status: Open Package: PCRE related
PHP Version: 7.3.15 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
49 + 11 = ?
Subscribe to this entry?

 
 [2020-03-09 18:27 UTC] jakob at givoni dot dk
Description:
------------
---
From manual page: https://php.net/migration73.incompatible
---
The section "Backward Incompatible Changes" on https://wiki.php.net/rfc/pcre2-migration
mentions many issues that would be nice to know before upgrading.
At the very least a link to this section should be provided on this migration page.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-03-12 09:12 UTC] nikic@php.net
Is there anything in particular that requires documentation here? Did you encounter some specific issue? The quoted section is mostly concerned with changes that are not user-visible.
 [2020-03-14 10:29 UTC] cmb@php.net
There is also a short section about the PCRE ugrade elsewhere in
the migration guide:
<https://www.php.net/manual/en/migration73.other-changes.php#migration73.other-changes.pcre>
 [2020-05-17 15:50 UTC] jakob at givoni dot dk
I feel I have answered to Nikita's question back in March, but as I don't see my comment here in the bug report, maybe something failed before it got submitted.

Anyway, the answer is yes, I encountered a specific issue after upgrading that I would have paid more attention to during upgrade, had I seen that my regexes might potentially break. I don't remember the exact error message anymore.

I know there's mention of changes to PCRE elsewhere, but I think it would be proper to put a link on https://php.net/migration73.incompatible pointing to https://wiki.php.net/rfc/pcre2-migration

If you want, I can submit the patch myself. Should I wait until the status changes to verified?
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 06:01:23 2020 UTC