php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #79322 Can we please have Windows builds for PHP 7.4+ ?
Submitted: 2020-02-29 17:39 UTC Modified: 2021-04-27 11:32 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: anrdaemon at yandex dot ru Assigned: cmb (profile)
Status: Closed Package: rrd (PECL)
PHP Version: 7.4.16 OS: Windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: anrdaemon at yandex dot ru
New email:
PHP Version: OS:

 

 [2020-02-29 17:39 UTC] anrdaemon at yandex dot ru
Description:
------------
Please? With a cherry on top.


Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-02-29 18:04 UTC] girgias@php.net
-Assigned To: +Assigned To: koubel
 [2020-03-01 09:05 UTC] cmb@php.net
The required fix has already committed to the repository[1], but a
new version has not been released since then.

[1] <http://svn.php.net/viewvc?view=revision&revision=341642>
 [2020-04-15 16:53 UTC] anrdaemon at yandex dot ru
So, can we please get a new version out?
This is the last ext that holding me down on 7.1.
 [2020-11-28 19:38 UTC] anrdaemon at yandex dot ru
Please?…

https://windows.php.net/downloads/pecl/releases/rrd/2.0.1/logs/
 [2021-04-21 18:54 UTC] anrdaemon at yandex dot ru
2.0.2 for 7.4+ did not build

https://windows.php.net/downloads/pecl/releases/rrd/2.0.2/logs/
 [2021-04-22 10:44 UTC] koubel@php.net
Latest source is on https://github.com/php/pecl-processing-rrd/. It was migrated from svn, so I think patches from Christoph are included. 2.0.2 was released some days ago.

Christoph can you look at why windows rrd build for php 7.4+ doesn't work?
 [2021-04-22 10:47 UTC] koubel@php.net
-Summary: Can we please have Windows builds for PHP 7.2+ ? +Summary: Can we please have Windows builds for PHP 7.4+ ? -Assigned To: koubel +Assigned To: cmb
 [2021-04-22 10:47 UTC] koubel@php.net
I'm changing the title - missing windows builds are for 7.4+ and assigning to Christoph for verifying. See my previous comment from 2021-04-22 10:44. Thanks.
 [2021-04-22 10:52 UTC] cmb@php.net
The following pull request has been associated:

Patch Name: Fix Windows build for PHP 7.4
On GitHub:  https://github.com/php/pecl-processing-rrd/pull/1
Patch:      https://github.com/php/pecl-processing-rrd/pull/1.patch
 [2021-04-22 10:53 UTC] cmb@php.net
-Assigned To: cmb +Assigned To: koubel
 [2021-04-22 10:53 UTC] cmb@php.net
See the linked pull request.
 [2021-04-22 15:10 UTC] koubel@php.net
thanks cmb@php.net - I merged the pull request, there are some build warnings on linux


rrd.h:197:5: note: expected ‘long unsigned int *’ but argument is of type ‘zend_ulong *’ {aka ‘unsigned int *’}
     unsigned long *,
     ^~~~~~~~~~~~~~~

rrd.c: In function ‘zif_rrd_xport’:
rrd.c:418:70: warning: passing argument 6 of ‘rrd_xport’ from incompatible pointer type [-Wincompatible-pointer-types]
  if (rrd_xport(argv->count-1, &argv->args[1], &xxsize, &start, &end, &step,
                                                                      ^~~~~
rrd.c:19:
/usr/include/rrd.h:229:5: note: expected ‘long unsigned int *’ but argument is of type ‘zend_ulong *’ {aka ‘unsigned int *’}
     unsigned long *,
     ^~~~~~~~~~~~~~~

rrd.c:419:3: warning: passing argument 7 of ‘rrd_xport’ from incompatible pointer type [-Wincompatible-pointer-types]
   &outvar_count, &legend_v, &data) == -1) {
   ^~~~~~~~~~~~~


but if it's good for windows builds, go on, maybe some another fix these if necessary :-).
 [2021-04-22 16:59 UTC] anrdaemon at yandex dot ru
As I've seen, the 7.3 build is also full of similar warnings, but succeed.
 [2021-04-22 21:13 UTC] anrdaemon at yandex dot ru
All newly packaged archives are missing gobject-2.dll
 [2021-04-23 09:50 UTC] koubel@php.net
-PHP Version: 7.2.28 +PHP Version: 7.4.16 -Assigned To: koubel +Assigned To: cmb
 [2021-04-23 09:50 UTC] koubel@php.net
I see there are windows builds already - https://pecl.php.net/package/rrd/2.0.3/windows. So I think bug is fixed and missing dll is another problem. But OK, I'm trying to change back to cmb.

Christoph, can you look at reported missing gobject-2.dll in latest generated packages on https://pecl.php.net/package/rrd/2.0.3/windows?
 [2021-04-23 11:31 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 [2021-04-23 11:31 UTC] cmb@php.net
Oh, this turns out to be ugly.  Apparently, the build system[1]
isn't capable of adding the gobject-2.dll, so this has been done
manually in the past (rrd 1.1.3).  I did that now for rrd 2.0.3 as
well, but it would be good to have that automated.

[1] <https://github.com/php/web-rmtools>
 [2021-04-23 11:32 UTC] cmb@php.net
> With a cherry on top.

Guess that was the manual adding of gobject-2.dll. :)
 [2021-04-25 06:26 UTC] anrdaemon at yandex dot ru
Thanks, I'm on PHP 7.4 now.

Have to wait for IMagick for next step, but that's a different problem.
 [2021-04-27 02:04 UTC] anrdaemon at yandex dot ru
Just a small note: The 7.3 and 7.4 packages (I checked TS ones) have gmodule-2.dll instead of gobject-2.dll

It can be retrieved from relevant 7.1 package, if anybody is stumbled upon this bug in the meantime.
 [2021-04-27 11:32 UTC] cmb@php.net
> The 7.3 and 7.4 packages (I checked TS ones) have gmodule-2.dll
> instead of gobject-2.dll

Oh, right!  That should be fixed now.

> […], but it would be good to have that automated.

Obviously.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 04:03:35 2021 UTC