php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79196 Problem with returning data when using bootstrap-3-typeahead
Submitted: 2020-01-30 09:30 UTC Modified: 2020-01-30 10:02 UTC
From: florencelehr at cnetmail dot net Assigned: cmb (profile)
Status: Not a bug Package: Testing related
PHP Version: 7.4.2 OS: Mac
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: florencelehr at cnetmail dot net
New email:
PHP Version: OS:

 

 [2020-01-30 09:30 UTC] florencelehr at cnetmail dot net
Description:
------------
I have a function in which there is a call to the database - a query in which several fields are returned. When I debug a piece of code in which rows from a database with several fields are returned, then I see rows from a database with several fields. Then the code transfers these lines to the front-end part, which is processed using bootstrap-3-typeahead. Lines with only one field come to the block on the front end - with the first field. Can this problem be caused by some prescribed function in the bootstrap-3-typeahead package itself, or is it my mistake?

Actual result:
--------------
On the backend returns:

Name / surname / position / company for which it works / company website / salary

Carl / cross / dental surgeon / big apple / big apple .com / 1.000
Colleen / simonsen / scientist / stm auto parts / stm auto parts .com / 9.000
Jason / curtiss / postsecondary career-technical teacher / big apple / big apple .com / 42.000
Gregory / johnson / college essay writer / college essay writing help company / https://bit.ly/2RGBDJY /33.000
Lara / montgomery / postsecondary career-technical teacher / hanover shoe / hanover shoe .com / 12.000
Glen / bassett / dental surgeon / hanover shoe / hanover shoe .com /22.000
William / williams / computer control operator / stm auto parts / stm auto parts .co / 12.000
Bradley / leon / entomologist / mikro designs / mikro designs . com / 12.000
 
And on the frontend this is inserted:

Carl
Colleen
Jason
Gregory
Lara
Glen
William
Bradley

Patches

Problemwithreturningdatawhenusingbootstrap-3-typeahead (last revision 2020-01-30 09:33 UTC by florencelehr at cnetmail dot net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-01-30 09:33 UTC] florencelehr at cnetmail dot net
The following patch has been added/updated:

Patch Name: Problemwithreturningdatawhenusingbootstrap-3-typeahead
Revision:   1580376805
URL:        https://bugs.php.net/patch-display.php?bug=79196&patch=Problemwithreturningdatawhenusingbootstrap-3-typeahead&revision=1580376805
 [2020-01-30 10:02 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2020-01-30 10:02 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat May 08 05:01:23 2021 UTC