php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #79142 [DE] http-build-query.php array example output missing URL encoding
Submitted: 2020-01-20 14:46 UTC Modified: 2020-01-26 18:07 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: bastian dot schaar at sedo dot com Assigned: cmb (profile)
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bastian dot schaar at sedo dot com
New email:
PHP Version: OS:

 

 [2020-01-20 14:46 UTC] bastian dot schaar at sedo dot com
Description:
------------
---
From manual page: https://php.net/function.http-build-query
---

The German translation includes example output for encoding multi-dimensional arrays which indicates that the resulting keys will *not* be URL encoded:

e.g. user[name]=Bob+Smith

The English version correctly shows the example output *with* URL encoded brackets.

e.g. user%5Bname%5D=Bob+Smith

Assuming that the implementation is correct, the documentation is not.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-01-20 14:57 UTC] cmb@php.net
-Summary: http-build-query.php array example output missing URL encoding +Summary: [DE] http-build-query.php array example output missing URL encoding -Status: Open +Status: Verified
 [2020-01-26 18:07 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&revision=349027
Log: Fix #79142: [DE] http-build-query.php array example output missing URL encoding
 [2020-01-26 18:07 UTC] cmb@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: cmb
 [2020-01-26 18:07 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 [2020-01-26 18:10 UTC] salathe@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/de.git;a=commit;h=4ff95f0c2d12fc635753e5aad2d06405895063be
Log: Fix #79142: [DE] http-build-query.php array example output missing URL encoding
 [2020-02-07 09:56 UTC] phpdocbot@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/de.git;a=commit;h=4fac335ab8bf1317ede23904856862df87d694c1
Log: Fix #79142: [DE] http-build-query.php array example output missing URL encoding
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Oct 19 22:01:23 2020 UTC