php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79130 make fails with 4.0.0
Submitted: 2020-01-16 15:04 UTC Modified: 2020-01-16 15:07 UTC
From: alfred dot bez at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: rar (PECL)
PHP Version: 7.4.1 OS: Ubuntu 18.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alfred dot bez at gmail dot com
New email:
PHP Version: OS:

 

 [2020-01-16 15:04 UTC] alfred dot bez at gmail dot com
Description:
------------
It's not possible to install the rar extension for PHP 7.4 by using the latest tagged package (4.0.0) listed on the pecl site (https://pecl.php.net/package/rar).

I was able to install the extension by using the source directly, see also: https://github.com/cataphract/php-rar/pull/4#issuecomment-575189247

It would be very helpful to tag a new release.

Test script:
---------------
Just follow the instructions on this page: https://www.php.net/manual/en/rar.installation.php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-01-16 15:07 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2020-01-16 15:07 UTC] cmb@php.net
Duplicate of bug #77267.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Feb 22 20:01:28 2020 UTC