php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79107 Undefined property: mysqli::$stat
Submitted: 2020-01-13 03:33 UTC Modified: 2020-01-13 03:35 UTC
From: bkfake-php at yahoo dot com Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: 7.4.1 OS: osx
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bkfake-php at yahoo dot com
New email:
PHP Version: OS:

 

 [2020-01-13 03:33 UTC] bkfake-php at yahoo dot com
Description:
------------
Undefined property: mysqli::$stat

client_info = mysqlnd 7.4.1


Test script:
---------------
$mysqli = new mysqli();
$mysqli->stat;  // triggers Undefined property

Expected result:
----------------
if above example, stat should be an empty string

Actual result:
--------------
Warning:  Undefined property

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-01-13 03:34 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2020-01-13 03:34 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

https://www.php.net/manual/en/mysqli.stat.php
 [2020-01-13 03:35 UTC] requinix@php.net
Oops. I meant to say


Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php
 [2020-01-13 04:14 UTC] bkfake-php at yahoo dot com
Update:  I may have a reading comprehension issue  

not sure if $stat property value was ever documented or when it went away, but able to use stat() method just the same.
 [2020-01-13 19:58 UTC] a at b dot c dot de
https://www.php.net/manual/en/migration74.incompatible.php#migration74.incompatible.mysqli

"The undocumented mysqli::$stat property has been removed in favor of mysqli::stat()."
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 19 22:03:37 2021 UTC