php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79039 pecl install ssh2 doesn't work
Submitted: 2019-12-27 13:15 UTC Modified: 2019-12-27 15:00 UTC
From: zelnaga at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: ssh2 (PECL)
PHP Version: Irrelevant OS: any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: zelnaga at gmail dot com
New email:
PHP Version: OS:

 

 [2019-12-27 13:15 UTC] zelnaga at gmail dot com
Description:
------------
"pecl install mcrypt" will install the latest version of mcrypt but "pecl install ssh2" doesn't. With ssh2 you have to do "pecl install ssh2-1.2". Seems a little silly. What if a new version of ssh2 is made available?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-12-27 15:00 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2019-12-27 15:00 UTC] cmb@php.net
By default, PECL is configured to only install *stable* versions
of packages.  However, the latest stable version is ssh2 0.13,
which does not support PHP 7.  Therefore you get the error
message:

  pecl/ssh2 requires PHP (version >= 4.0.0, version <= 6.0.0), installed version is 7.x.y

Use `pecl install ssh2-beta` to get the latest beta version (i.e.
1.2), until a stable version has been released.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Apr 13 08:01:29 2024 UTC