php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #79008 General performance regression with PHP 7.4 on Windows
Submitted: 2019-12-20 15:23 UTC Modified: 2019-12-20 15:23 UTC
From: cmb@php.net Assigned: cmb (profile)
Status: Closed Package: Performance problem
PHP Version: 7.4Git-2019-12-20 (Git) OS: Windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: cmb@php.net
New email:
PHP Version: OS:

 

 [2019-12-20 15:23 UTC] cmb@php.net
Description:
------------
The reworking of the Windows stat implementation for PHP 7.4[1]
caused an fstat() related performance regression compared to PHP
7.3, which is most serious with OPcache disabled, where it makes
scripts and applications about 10% slower.

This is because fstat() now tries to retrieve the filename of the
stream to properly set the executable bits (S_IEXEC) of the
st_mode member, while formerly it did not (instead native Windows
fstat() and friends have been called).

[1] <http://git.php.net/?p=php-src.git;a=commit;h=e42e8b1051a8abeaa8e6053653a4ff43438766e2>


Test script:
---------------
<?php
echo 'hello world';


Expected result:
----------------
something like
<https://windows.php.net/downloads/snaps/ostc/pftt/perf/7.3.12-7.4-cmb5ca0294.html>


Actual result:
--------------
something like
<https://windows.php.net/downloads/snaps/ostc/pftt/perf/7.3.12-7.4.0.html>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-12-20 15:23 UTC] cmb@php.net
-Assigned To: +Assigned To: cmb
 [2019-12-20 15:30 UTC] cmb@php.net
Automatic comment on behalf of cmbecker69@gmx.de
Revision: http://git.php.net/?p=php-src.git;a=commit;h=6ec40569281e2c392dd14da00319bd10d1c5d3d6
Log: Fix #79008: General performance regression with PHP 7.4 on Windows
 [2019-12-20 15:30 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 18 23:03:49 2022 UTC