php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78951 Unable to load library
Submitted: 2019-12-12 10:37 UTC Modified: 2019-12-12 13:29 UTC
From: rybachok91 at mail dot ru Assigned: cmb (profile)
Status: Not a bug Package: Compile Warning
PHP Version: 7.4.0 OS: Arch Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rybachok91 at mail dot ru
New email:
PHP Version: OS:

 

 [2019-12-12 10:37 UTC] rybachok91 at mail dot ru
Description:
------------
Hello! After update php to version 7.4.0-2 a got an error
PHP Warning:  PHP Startup: Unable to load dynamic library 'oci8.so' (tried: /usr/lib/php/modules/oci8.so (/usr/lib/php/modules/oci8.so: undefined symbol: add_index_zval)

Test script:
---------------
I just run command "php -v" in terminal


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-12-12 11:44 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2019-12-12 11:44 UTC] cmb@php.net
From where did you get oci8.so?
 [2019-12-12 12:06 UTC] fgfgfgfg at somewhere dot com
you extensions below /usr/lib/php/modules/ are simply built not for PHP 7.4.0 and especially for pecl-extensions (https://bugs.php.net/bug.php?id=78948) you are responsible at your own to ret them rebuilt

not a bug in PHP
 [2019-12-12 12:09 UTC] rybachok91 at mail dot ru
From this https://pecl.php.net/package/oci8
Installed version php-oci8  2.2.0-1
 [2019-12-12 12:14 UTC] nikic@php.net
You need to rebuild the extension for PHP 7.4. Possibly the simplest way to do that is to just uninstall it and reinstall?

Normally extensions for different PHP API versions are installed in separate directories to avoid this kind of issue. However, it seems that your distro installs everything in one location.
 [2019-12-12 12:30 UTC] rybachok91 at mail dot ru
Reinstalling is not help. I had the same error.
 [2019-12-12 12:59 UTC] rybachok91 at mail dot ru
I've reinstalled in second time. And it's work. Sorry, but I don't understand, why it's happened. Thank you!
 [2019-12-12 13:29 UTC] cmb@php.net
-Status: Feedback +Status: Not a bug
 [2019-12-12 13:29 UTC] cmb@php.net
Great that this issue has been resolved!  As it's not a bug in
PHP, closing as such.
 [2019-12-12 13:33 UTC] retertertert at fgfgfg dot com
the error message could be serious improved and mention the ABI incompatibility and that the extension needs to be rebuilt, the current one is only understood by people knowing a lot of php internals
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 08:01:23 2020 UTC