php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78922 how to configure gnupg
Submitted: 2019-12-07 09:28 UTC Modified: 2019-12-07 09:49 UTC
From: naveennavi dot marina at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: *Configuration Issues
PHP Version: 7.2.25 OS: ubuntu
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: naveennavi dot marina at gmail dot com
New email:
PHP Version: OS:

 

 [2019-12-07 09:28 UTC] naveennavi dot marina at gmail dot com
Description:
------------
---
From manual page: https://php.net/book.gnupg
---
I want to encrypt my data using pgp public key.i am using openpgp-library for encrypt my data.but my client side they don't decrypt the my encrypted data.
They suggested to use gnupg library.

I have installed gnupg on following step on below url.but i can't create a gnupg object in my php file.i can't find any solution on related issue in internet and also i am discussed with my senior person  they all are said we are never use that.if i create a gnpug object it throw class not found exception.i don't know what i am doing wrong.i am stucked with last one week please help me.

https://www.php.net/manual/en/gnupg.installation.php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-12-07 09:49 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2019-12-07 09:49 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Dec 03 08:03:33 2021 UTC