php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #78882 str_split on a utf8 line complains about 8-bit chars
Submitted: 2019-11-28 18:12 UTC Modified: 2019-12-08 04:22 UTC
From: fidhleir99 at gmail dot com Assigned:
Status: No Feedback Package: Documentation problem
PHP Version: 7.3.12 OS: FreeBSD 11.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fidhleir99 at gmail dot com
New email:
PHP Version: OS:

 

 [2019-11-28 18:12 UTC] fidhleir99 at gmail dot com
Description:
------------
---
From manual page: https://php.net/function.str-split
---
    "Note:

    str_split() will split into bytes, rather than characters when dealing with a multi-byte encoded string."

If it's splitting into bytes, then it shouldn't be complaining about 8-bit values.  But it does. 




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-11-28 20:43 UTC] requinix@php.net
-Status: Open +Status: Feedback
 [2019-11-28 20:43 UTC] requinix@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves.

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external
resources such as databases, etc. If the script requires a
database to demonstrate the issue, please make sure it creates
all necessary tables, stored procedures etc.

Please avoid embedding huge scripts into the report.


 [2019-12-08 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jul 12 13:01:26 2020 UTC