php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7884 php and apache configuration to enable 'copy' to write on a network drive
Submitted: 2000-11-20 03:49 UTC Modified: 2001-05-24 18:50 UTC
From: benoit dot martin at alcatel dot fr Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.3pl1 OS: WindowsNT
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: benoit dot martin at alcatel dot fr
New email:
PHP Version: OS:

 

 [2000-11-20 03:49 UTC] benoit dot martin at alcatel dot fr
Hi,

I have an Apache Server and PHP 4.0.3pl1 installed on WindowsNT.
I am trying to make the following script work
The pb is when the destination file is on c:\dir\$Fichier_dest it works
but when i use a virutal letter F:\ that point on a network computer,
the answer is unable to create file 'myfile' : permission denied !
Whereas on the network drive all users have all rights !
and when a try the same thing in a MS-DOS window (copy c:\myfile.txt
f:\myfile.txt) it works !!!!!
does anyone can help me ????

Can somebody try this script on an apache server ??????

the script :

<html>

<?
 if ($Fichier && $Fichier != "none") {

 echo "<U><B>Votre fichier :</B></U><BR>";
 echo "Fichier sur serveur : $Fichier<BR>";
 echo "Fichier envoy?      : $Fichier_name<BR>";
 echo "Taille              : $Fichier_size<BR>";
 echo "Type                : $Fichier_type<BR>";
 $Fichier_dest = "f:\\".$Fichier_name;


 if (!copy($Fichier, $Fichier_dest)) {
       print ("failed to copy $Fichier_dest <br>\n");
  echo "$php_errormsg";
      } else {
  print ("$Fichier_dest copi?...");
 }

}

?>
<BODY>
<FORM ENCTYPE="multipart/form-data" METHOD="POST">
<INPUT TYPE="hidden" name="MAX_FILE_SIZE" value="100000">
Envoyer le fichier : <INPUT NAME="Fichier" TYPE="file">
<INPUT TYPE="submit" VALUE="Envoyer le fichier">
</FORM>
</BODY>
</HTML>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-24 18:50 UTC] cardinal@php.net
Verbatim duplicate of #7860
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 21 21:01:33 2024 UTC