php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #78753 [RU] Wrong description of options parameter in setcookie doc page
Submitted: 2019-10-26 02:45 UTC Modified: 2019-10-26 14:21 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: sageptr at gmail dot com Assigned: sergey (profile)
Status: Closed Package: Translation problem
PHP Version: 7.3.11 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: sageptr at gmail dot com
New email:
PHP Version: OS:

 

 [2019-10-26 02:45 UTC] sageptr at gmail dot com
Description:
------------
On this manual page https://www.php.net/manual/ru/function.setcookie.php :

```
options
Ассоциативный массив (array), который может иметь любое из ключей lifetime, path, domain, secure, httponly и samesite. Значения имеют тот же смысл, как описано в параметрах с соответсвующим именем. Значение элемента samesite должно быть либо Lax, либо Strict. Если какая-либо из допустимых опций не указана, ее значения по умолчанию совпадают с значениями по умолчанию для явных параметров. Если элемент samesite не указан, cookie-атрибут SameSite не установлен.
```

But the key is called "expires", not "lifetime". Passing "lifetime" key doesn't work and it's simply ignored. The English version of manual is correct and states the key as "expires", so it's a problem with the Russian translation.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-10-26 12:41 UTC] sergey@php.net
-Assigned To: +Assigned To: sergey
 [2019-10-26 12:52 UTC] sergey@php.net
Automatic comment from SVN on behalf of sergey
Revision: http://svn.php.net/viewvc/?view=revision&revision=348222
Log: fix(ru): Bug #78753
 [2019-10-26 14:21 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 [2019-10-26 14:21 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 20:01:29 2024 UTC