php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78726 opcache_invalidate fails
Submitted: 2019-10-22 19:26 UTC Modified: 2019-10-23 17:34 UTC
From: v-altruo at microsoft dot com Assigned:
Status: Closed Package: Testing related
PHP Version: 7.4.0RC4 OS: Windows Server 2012 R2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: v-altruo at microsoft dot com
New email:
PHP Version: OS:

 

 [2019-10-22 19:26 UTC] v-altruo at microsoft dot com
Description:
------------
Test seems to only fail on this windows operating system for x86 TS build with opcache enabled.

Failed Test: ext\opcache\tests\bug69195.phpt

Expected result:
----------------
string(1) "a"
bool(true)
string(1) "b"

Actual result:
--------------
string(1) "a"
bool(false)
string(1) "a"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-10-22 21:47 UTC] v-altruo at microsoft dot com
Test also fails (same output) for windows server 2019. However, for all builds whenever opcache is enabled.
 [2019-10-23 17:34 UTC] v-altruo at microsoft dot com
-Status: Open +Status: Closed
 [2019-10-23 17:34 UTC] v-altruo at microsoft dot com
Re-downloaded 7.4.0RC4 build and tested again. They work fine now.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jun 19 22:01:22 2021 UTC