|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78615 openssl don't load
Submitted: 2019-09-30 23:47 UTC Modified: 2019-10-01 04:16 UTC
From: diego dot galarzam at gmail dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 7.2.23 OS: Windows server 2012 R2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: diego dot galarzam at gmail dot com
New email:
PHP Version: OS:


 [2019-09-30 23:47 UTC] diego dot galarzam at gmail dot com
I tried to load extension php_openssl, then apache put in error log: Unable to load dynamic library 'openssl'.. 

I can load pdo_oci in the same directory.

I can load php_openssl in Windows 10, 7 and I don't have any problems.

I have just problem with Windows Server 2012 R2.

I tried with Php 7.3.x and php 7.2.x NTS and TS

I tried with apache 4.3 and 4.2   openssl and libre openssl

Any Ideas ? 


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2019-10-01 04:16 UTC]
-Status: Open +Status: Not a bug
 [2019-10-01 04:16 UTC]
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jul 14 15:01:28 2024 UTC